segmentation fault on redhat enterprise linux

Michael Ströder michael at stroeder.com
Wed Aug 4 16:15:58 CEST 2004


Christian Guenther wrote:
> 
> I have a bunch of python and shell scripts that manage my 150+ users  
> and groups in ldap and
> generate necessary links and aliases for them. The scripts used to work  
> perfectly on RedHat 9
> and also on Debian 3 - they even workm on my Apple Powerbook under Mac  
> OS X Panther.

Well, which versions of OpenLDAP and cyrus-sasl do you have on these systems?

>     RedHat Enterprise Linux ES 3
>     Python 2.0.2
>     Openldap 2.0.27
>     OpenSSL 0.9.7a
>     cyrus sasl 2.1.15

RedHat's support for OpenLDAP is bad.
I'd recommend to upgrade cyrus-sasl and OpenLDAP libs.

Note that libldap_r is not available for OpenLDAP 2.0.x. Please make sure 
your setup.cfg reflects this.

>     kernel 2.0.23 with XFS support - self compiled

2.0? Why such an old kernel?

>     python-ldap 2.0.2 compiled from tarball

What's the output of

# ldd /usr/lib/python2.0/site-packages/_ldap.so

Ciao, Michael.



More information about the python-ldap mailing list