Backward compability older Python versions

Marc Balmer marc at
Fri Mar 4 14:26:11 CET 2005

Michael Ströder wrote:

>> IIRC Python 2.1.3 is the standard version of Python included in Debian 
>> Woody which is still (unfortunately) the stable Debian release so 
>> please keep this in mind when you'll decide. 
> Hmm, regarding Linux distributions also the versions of the OpenLDAP 
> libs come to mind. I'd like drop support for older OpenLDAP libs too to 
> get rid of all the #ifdef's spreaded around in the C source.

If "they" still stick to old python versions, then they should probably
use an old python-ldap as well.  I'd rather like to see a recent 
python-ldap implementation using a recent python interpreter and recent 
openldap libraries.

python-ldap is not only used on Debian Woody so please keep this in mind 
as well when you'll decide...

Marc Balmer

mbalmer at

More information about the python-ldap mailing list