Backward compability older Python versions

Deepak Giridharagopal deepak at
Fri Mar 4 20:00:08 CET 2005

On Fri, 2005-03-04 at 12:13 +0100, Michael Ströder wrote:
> For various reasons it is difficult to support older versions of Python. 
> Especially supporting 1.x is a pain with newer modules written in 
> Python. 

Python-ldap works with Python 1.x? The INSTALL doc says that 2.0+ is a
prerequisite. I ask because the patches I've thrown out there haven't
been tested on 1.x...

> Personally I'd like to be drop support for any Python version earlier 
> than 2.3. This would make it possible to use standard modules like sets 
> and datetime which could make life easier.



Deepak Giridharagopal

More information about the python-ldap mailing list