python-ldap and mac os x tiger, missing symbols

Michael Ströder michael at
Tue May 17 22:36:12 CEST 2005

Jens Vagelpohl wrote:
> On May 17, 2005, at 21:58, Bethany Jane Hanson wrote:
>> Hi Jens!  I tried building python 2.4.1 and python-ldap 2.0.7 last
>> night.  Both of them built and installed without errors, but when I
>> ran Python and tried to use the ldap module it complained about
>> missing symbols again:
>> [..]
>> ImportError: Failure linking new module: /usr/local/lib/python2.4/
>> site-packages/ Symbol not found: _ldap_matchingrule_free
>>   Referenced from: /usr/local/lib/python2.4/site-packages/
>>   Expected in: dynamic lookup
> I did not see these problems after compiling Python 2.4.1 and python-
> ldap HEAD from CVS anymore, there's not much I can say - it worked
> for me.

Well, then it should also work with python-ldap 2.0.7 compiled from
source since at the moment there's no new code in CVS HEAD.

Ciao, Michael.

More information about the python-ldap mailing list