_ldap.so: undefined symbol: ber_flatten2

Michael Ströder michael at stroeder.com
Thu Jul 20 13:11:24 CEST 2006

Michele Marcionelli wrote:
>     OpenLDAP 2.0.27
>     python-ldap-2.0.11
> [..]
> ImportError: /usr/local/lib/python2.3/site-packages/_ldap.so:  undefined
> symbol: ber_flatten2
> [..]
> What is wrong? It sould also be possible to use OpenLDAP 2.0 (not  only
> 2.1)?

Hmm, python-ldap 2.0.11 was supposed to work with OpenLDAP 2.0.x but
adding a user-contributed patch for LDAPv3 controls used function
ber_flatten2(). Obviously this change was not available in the 2.0.11
release yet:


Well, since OpenLDAP 2.0.27's libldap is really ancient and very buggy
compared to today's versions I'm not keen on supporting this OpenLDAP
version anymore. It's really time to upgrade now.

Ciao, Michael.

More information about the python-ldap mailing list