error when build and install

Matej Vela vela at
Wed May 9 17:13:40 CEST 2007

"Einar Næss Jensen" <einar.nass.jensen at> writes:

> trying to build on debian etch, with ssl, I get this error:
> ldap-python version is 2.3
> python-version is 2.4.4
> openssl and sasl are installed
> Modules/constants.c: In function *LDAPinit_constants*:
> Modules/constants.c:178: error: *LDAP_OPT_X_TLS_CRLCHECK* undeclared
> (first use in this function)
> I have an earlier version of python-ldap, 2.0-pre19 (I I remember
> correctly) which is no trouble at all installing.

The current version of python-ldap requires version 2.3.0 of OpenLDAP
libraries, while Etch provides 2.1.30.  (AFAIK, this is mostly due to
compatibility problems that would arise if an application simultaneously
used differing versions of libldap and libnss-ldap.  Etch does ship with
slapd 2.3.30.)

If you don't mind using a slightly older version (2.2.1), simply install
the Debian package:

    # apt-get install python-ldap

If you'd like to compile your own, apply the Debian patch from



More information about the python-ldap mailing list