Local error in simple_bind_s() continued

Michael Ströder michael at stroeder.com
Mon Mar 3 21:30:45 CET 2008

Leons Petrazickis wrote:
> I just installed Suse Linux Enterprise Desktop 10. It comes with OpenLDAP
> 2.3.19 and Python 2.4. On top of that, I built the latest CVS checkout of
> python-ldap.

Could you please try to install Ralf Haferkamp's recent OpenLDAP 
RPMs for SLE 10 from here and rebuild python-ldap:


> I am getting the same error as with Ubuntu. OpenLDAP works, but python-ldap
> crashes. Previous thread:
> <http://sourceforge.net/mailarchive/forum.php?thread_name=OFB4CEB31F.56A5A98B-ON852573B1.00808384-852573B1.0081B67C%40ca.ibm.com&forum_name=python-ldap-dev

Hmm, frankly I have no idea.

> import ldap;
> ldap.set_option(ldap.OPT_DEBUG_LEVEL,4095);
> l = ldap.initialize("ldap://bluepages.ibm.com:636/",trace_level=2);
> l.simple_bind_s();
> This is the output:

You're setting trace_level=2 but there are no python-ldap debug 
messages in your output at all.

> The host is running Tivoli Directory Server 5.2.

I'm pretty sure I've already accessed this LDAP server with 
web2ldap, hence python-ldap worked. Don't remember the versions 

Ciao, Michael.

More information about the python-ldap mailing list