ldap.ENCODING_ERROR when trying to use SimplePageResultsControl

Michael Ströder michael at stroeder.com
Thu Mar 5 15:22:23 CET 2009

pyldap.20.dlobue at neverbox.com wrote:
> I've run into the same problem as Joel on basically an identical setup
> - CentOS 5.2, openldap 2.3.27-8.el5_2.4, python 2.4.3-21.el5,
> python-ldap 2.2.0-2.1. This of course being on a 64 bit release of
> CentOS.
> I did as you suggested and updated openldap to 2.4.12-1, and
> python-ldap to 2.3.5-1, but I still received the exact same error.

The problem with using binary packages is that I never know whether
patches were applied by the distributor and which build parameters were

Also note there's python-ldap with some minor build fixes and OpenLDAP
2.4.15 with numerous fixes to libldap. OpenLDAP developers will likely
not give support with this issue if the problem cannot be reproduced
with recent code.

> Because you mentioned that you had never tested python-ldap on a 64
> bit machine, I duplicated my setup in a VirtualBox VM only using a
> i686 release of CentOS rather than x64.
> I ran my python program using the old versions of software ( openldap
> 2.3.27-8.el5_2.4, python 2.4.3-21.el5, python-ldap 2.2.0-2) and it ran
> without any problems whatsoever.

Thanks for testing this.

> Any suggestions on how to fix this?

At the moment I have no idea how to proceed. I'd suggest to build from
source. Not sure about compiler woes on that platform. E.g. try turning
off optimization (with option -O0) when building from source.

Ciao, Michael.

More information about the python-ldap mailing list