python-ldap-2.3.12: Compile error on CentOS 5.5, i386

Zhang Huangbin zhbmaillistonly at gmail.com
Thu Aug 12 06:06:46 CEST 2010


On Aug 12, 2010, at 2:42 AM, Michael Ströder wrote:
> 
> Looks like an older OpenLDAP release. Please try the patch below.
> 
> Ciao, Michael.
> 
> Index: Modules/constants.c
> ===================================================================
> RCS file: /cvsroot/python-ldap/python-ldap/Modules/constants.c,v
> retrieving revision 1.47
> diff -u -r1.47 constants.c
> --- Modules/constants.c	7 May 2010 13:22:40 -0000	1.47
> +++ Modules/constants.c	11 Aug 2010 05:14:47 -0000
> @@ -181,7 +181,9 @@
> #ifdef LDAP_OPT_X_TLS_CRLCHECK
>   /* only available if OpenSSL supports it => might cause backward
> compability problems */
> 	add_int(d,OPT_X_TLS_CRLCHECK);
> +#ifdef LDAP_OPT_X_TLS_CRLFILE
> 	add_int(d,OPT_X_TLS_CRLFILE);
> +#endif
> 	add_int(d,OPT_X_TLS_CRL_NONE);
> 	add_int(d,OPT_X_TLS_CRL_PEER);
> 	add_int(d,OPT_X_TLS_CRL_ALL);


This patch fixes it.
Will you release a 2.3.12.1 version for this fix?






More information about the python-ldap mailing list