Minimum version of OpenLDAP libs for python-ldap 2.4.x?

Zhang Huangbin zhbmaillistonly at
Sat Mar 5 04:08:33 CET 2011

On Mar 5, 2011, at 2:45 AM, Michael Ströder wrote:

> Again it's time to think about the minimum required version of OpenLDAP libs
> to be used for building upcoming python-ldap 2.4.0.

Does it mean py-ldap-2.4.0 won't support OpenLDAP-2.3.x series?

Debian 5, RHEL/CentOS 5 ships OpenLDAP-2.3.x.

I don't think it's a good strategy to force sys admin to compile/install openldap-2.4 on  production server, if they want to update openldap, they have to compile again and again.

More information about the python-ldap mailing list