[python-ldap] older python versions not available anymore

Peter Jacobs peter.jacobs at icts.kuleuven.be
Tue Jun 7 21:13:39 CEST 2011

Op 7/06/2011 19:28, Michael Ströder schreef:
> Peter Jacobs wrote:
>> We use the python-ldap library in our Plone installations.
>> Recently when running a buildout installation script, it broke when
>> downloading python-ldap version 2.3.11.
> Can you please give more details?
We use the zc.buildout tool to install our Plone/Zope app.
It has a nice feature that allows you to easily download and install 
packages with a specific version, so you can have repeatable 
installations and go back to a situation in the past. 

in my installation script I use the following line:

The error when I run the installation script:
Getting required 'python-ldap==2.3.11'
We have no distributions for python-ldap that satisfies 
Getting distribution for 'python-ldap==2.3.11'.
   Installing instance.
   Getting distribution for 'python-ldap==2.3.11'.
Error: Couldn't find a distribution for 'python-ldap==2.3.11'.
which is logical because it is not available on pypi anymore

when i replace it with: python-ldap=2.3.13 , buildout finds 
python-ldap-2.3.13.tar.gz   and the installation succeeds.

You could argue that it is best practice not to stick with old versions.
That may work fine for python developers who follow up very closely on 
the packages used, but is much harder for integrators who use complex 
applications like plone.
See for example : http://dist.plone.org/release/3.3.5/versions.cfg . It 
does not include python-ldap, but other python packages. There are many 
interdependent packages that are tested in combination, isn't it a bit 
harsh to force people who depend on a version of a package to fix their 
installation scripts sito presto, by removing those versions from the 
pypi repository?

>> It turns out that this version has been removed from pypi:
>> http://pypi.python.org/packages/source/p/python-ldap/
>> This seems to me very inconvenient for a lot of people, as we depend on
>> specific versions of packages.
>> E.g. on our RedHat 5.5 server we cannot use 2.3.12 because it gives an error
>> (dependency on some version of some other system library?)
> Which error? Note that in 2.3.13 there was a build error fixed for older
> OpenLDAP libs which affected older RHEL versions etc.
Ah indeed, with 2.3.13 the installation on RHEL5.5 works again. Thank 
you, that way I can fix the installation scripts.
Still, I was happy we had pinned our package versions to 2.3.11 so we 
could keep our installation working when 2.3.12 was released...

>> We will try to solve this issue for ourselves by implementing our own local
>> egg cache, but I think it would be a plus for many people to keep older
>> versions online?
> Hmm, I'm not convinced...
If I am the only one complaining and others do update their package 
versions timely, you can safely ignore this request :-)

Thanks for your time and advice,

More information about the python-ldap mailing list