[python-ldap] Mac OS X 10.7 (Lion)

Michael Ströder michael at stroeder.com
Thu Jul 28 16:20:55 CEST 2011


Please always follow-up on the mailing lists so others can comment and/or
learn as well.

Rob McBroom wrote:
> On Jul 28, 2011, at 9:14 AM, Michael Ströder wrote:
> 
>> As documented OpenLDAP libs 2.4.11 or newer are required to build and install
>> python-ldap 2.4.x:
>>
>> http://www.python-ldap.org/doc/html/installing.html#prerequisites
>>
>> OpenLDAP 2.4.11 was released three years ago now (2008/07/16).
> 
> Requiring something that’s been out for 3 years seems pretty safe to me.
> 
> For what it’s worth, the OpenLDAP server and client tools bundled with Lion are 2.4.23, but if I’m interpreting this correctly, the library is nowhere near that:
> 
>     % otool -L /usr/lib/libldap_r.dylib
>     /usr/lib/libldap_r.dylib:
>         /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP (compatibility version 1.0.0, current version 2.2.0)

I'm not familiar with MAC OS X and the file system used for the libs.
Maybe you have to install additional development files like on Linux boxes? Is
ldap.h around at all?

Ciao, Michael.


More information about the python-ldap mailing list