[python-ldap] Pip install failure

Michael Ströder michael at stroeder.com
Wed Feb 29 10:48:07 CET 2012

Kenneth Koski wrote:
> Not quite sure if this is a python-ldap issue, or a pip issue. Reporting a
> bug/feature request here, though, and if someone can redirect me to the right
> group, I'll send it that way.
> At any rate, I'm running Ubuntu 10.04 with virtualenv. I tried doing a "pip
> install python-ldap", which apparently tried to build from source. It failed
> with the error message "too many arguments to function ‘interaction’". After
> doing some Google searching it turns out that the libraries libldap2-dev,
> libsasl2-dev, and libssl-dev are required. It seems like there should be a
> more informative way of letting the user know that they need to install these
> libraries without requiring them to resort to using a search engine.

Feel free to contribute appropriate text for this doc section:


But bear in mind that the Linux distributions all have different package 
systems and package names - even changing from distro version to version. So 
there should not be too much platform-specific stuff in your text.

I tried to write up something for my web2ldap which is based on python-ldap:


But the drawback is that this is only a example for a specific Debian version 
and the admin still might have to check out some things himself.

It might be better to tell the Ubuntu developers to update their python-ldap 
package because this is likely the reason why you installed via pip.

Ciao, Michael.

P.S.: If you plan to post more to python-ldap mailing list please subscribe to 
it so you can receive the follow-ups and I don't have to manually approve your 
postings. The mailing list is very low traffic.

More information about the python-ldap mailing list