[python-ldap] Where to Download Python-ldap for Python-2.7.2 and Openldap-2.2.13-4

Michael Ströder michael at stroeder.com
Wed Feb 29 16:24:14 CET 2012

Jen Tille wrote:
> I want a python-ldap tarball which I can compile for Python-2.7.2 and
> openldap-2.2.13-4. The two latest python-ldap packages do not work because
> they need a newer openldap. Where can I download a python-ldap tarball that I
> can compile for the above mentioned versions?

Note that OpenLDAP 2.2.13 is really ancient! It was released almost eight 
years ago and should not be used anymore. 2.2.x series has not been maintained 
by OpenLDAP developers for years. You won't get support for this anywhere. You 
definitely cannot compile recent python-ldap releases on such a platform.

If you're stuck on a certain Linux distribution (I guess old RHEL 4 or 
earlier) you should either
1. stick to Python and python-ldap packages provided for this distribution
2. also compile recent OpenLDAP, OpenSSL and SASL libs yourself to a separate 
prefix (take care of run-time linking issues!).

Ciao, Michael.

More information about the python-ldap mailing list