<div dir="ltr"><div><div><div><div><div>I'm on OSX 10.11.3 and I installed python-ldap 2.4.25 with pip in a virtualenv. And I always get this error:<br><br>>>> import ldap<br>>>> ldap.set_option(ldap.OPT_X_TLS_CACERTFILE, '/path/to.crt')<br>Traceback (most recent call last):<br>  File "<stdin>", line 1, in <module><br>  File "/Users/peterbe/virtualenvs/medlem/lib/python2.7/site-packages/python_ldap-2.4.25-py2.7-macosx-10.11-x86_64.egg/ldap/functions.py", line 133, in set_option<br>    return _ldap_function_call(None,_ldap.set_option,option,invalue)<br>  File "/Users/peterbe/virtualenvs/medlem/lib/python2.7/site-packages/python_ldap-2.4.25-py2.7-macosx-10.11-x86_64.egg/ldap/functions.py", line 64, in _ldap_function_call<br>    result = func(*args,**kwargs)<br>ValueError: option error<br><br></div>It doesn't matter what the value of that option is. <br></div>It does not happen when installed on Ubuntu. <br><br></div>Axel here, <a href="http://stackoverflow.com/a/29101851/205832">http://stackoverflow.com/a/29101851/205832</a> said he managed to make the problem go away by downloading the tarball and adding /usr/local to setup.cfg. That did not help for me. <br><br></div>For what it's worth, I *have* /usr/include/sasl/ on my disk. <br><br></div>Peter<br><div><div><div><div><div><div><div><br clear="all"><div><br>-- <br><div class="gmail_signature"><div dir="ltr"><div><div dir="ltr">Peter Bengtsson<br>Mozilla Tools & Services<br></div></div></div></div>
</div></div></div></div></div></div></div></div></div>