why are dlopen flags different between 1.5 and 1.5.2?

Michael Hudson mwh21 at cam.ac.uk
Sat Aug 7 11:03:31 CEST 1999


Bill Janssen <janssen at parc.xerox.com> writes:

> After a fair amount of grief, I found out that while Python 1.5
> specified RTLD_GLOBAL in its call to dlopen (in Python/importdl.c),
> Python 1.5.2 does not.  Is there any particular reason to change this?

It was thrashed out here a while's back. www.deja.com is your
friend... I think there was also discussion on PSA-members or some sig
or other.

I think the basic gist was that if not using RTLD_GLOBAL causes you
problems you can do something about it, whereas if using RTLD_GLOBAL
causes you problems you are screwed.

> To be compatible with Java?

I doubt it.

> Bill

HTH
Michael




More information about the Python-list mailing list