Python an Tcl/Tk 8.1

Dieter Maurer dieter at handshake.de
Mon Jun 7 22:42:47 CEST 1999


Hello Jared

Jared Hanson wrote:
> I am new to all of this.  I am running Windows 98, and I just downloaded
> Python and the newest version of Tcl/Tk (8.1).  Unfortunately, it appears
> that Python doesn't like this version.  Doing an import Tkinter command
> prints out an error message saying that its looking for 8.0 dlls.  I was
> wondering what files I need to change to point to 8.1 dlls in order to make
> it work (if that would make it work at all)  Or do I just need to get a copy
> of the 8.0 dlls and stick them in the same folder.  Any help you could offer
> me would be appreciated, just reply to my post.
"Tkinter" as distributed in 1.5.2 will not work with Tk8.1 due
to minor changes in the Tk startup requirements.

To use "Tkinter" with Tk8.1, you must apply the two patches
I posted recently to this newsgroup, and then regenerate
"_tkinter.pyd" with the Tcl/Tk 8.1 distribution.
Thus, you need a source distribution of both
Python and Tcl/Tk and a C development system.

- Dieter





More information about the Python-list mailing list