DLL prob win32com, old, resolved

Bernhard Reiter bernhard at alpha1.csd.uwm.edu
Fri Jun 18 01:04:29 CEST 1999


way back on the 9th of April, I reported the following problem:

| Get strange errors, when using PythonWin (win32all-124)
| with Python 1.5.2b2 or 1.5.2c1 on this Windows 95 machine here.
| The installprogram said that
|         AXScript, Python Interpreter and Python Dictionary
| couldn't be registered. Should be registered manually.
| 
| When importing COM stuff, I get:
| import pythoncom
| Traceback (innermost last):  File "<interactive input>", line 1,
| in ?ImportError:
| DLL load failed: A device attached to the system is not functioning.
| 
| Reading documentation I know about possible old COM dlls as noted on
| http://starship.python.net/crew/mhammond/bigpond/Downloads.html
| but my error message seems to be different.

I updated a few Dlls and the one's that Mark suggested, but it didn't help.
Now I had the same problem on a different machine again and
Chris Tavares <tavares at connix.com> in <370F78E2.8EA7433E at connix.com>
was right (on the 10th of April):

| Another option is to download DCOM for Win95 - that'll get the user up to date
| and then some!

I tried that this time and it worked! Hurray!
Part of the problem, why I didn't tried that the last time was, that
I couldn't find DCOM on the support.microsoft.com site. (The search
enginge is really bad.)
Stupid me, it is no support it can be reached from: 
	http://www.microsoft.com/msdownload/
search for "DCOM95".

Problem could be solved with that, finally.
Mark: you might want to add that hint for other desperate users now.
I recall at least one additional question regarding that.

	Bernhard
-- 
Research Assistant, Geog Dept UM-Milwaukee, USA.         (www.uwm.edu/~bernhard)
Funding/Promoting Association for a Free Informational Infrastructure (ffii.org)




More information about the Python-list mailing list