Platform independent? (Was: Drawing (directed) graphs)

Adrian Eyre a.eyre at optichrome.com
Tue Nov 16 14:45:01 CET 1999


>> This is why it annoys me that some of the scripts in the
>> standard Python library are not platform independent, but
>> rely on non-portable features of posix.

> If you know of ways to reduce the platform-dependence of these,
> please feel free to submit patches!

I'm sure a lot of the base SocketServer stuff could be rewritted
to use the select module (which will port to Win32).

The other alternative (if this is not possible) is to move any
scripts in Python's Lib/ directory which are dependent on posix
into a subdirectory called plat-posix/ much like the plat-win/
stuff.

--------------------------------------------
Adrian Eyre <mailto:a.eyre at optichrome.com>
Optichrome Computer Solutions Ltd
Maybury Road, Woking, Surrey, GU21 5HX, UK
Tel: +44 1483 740 233  Fax: +44 1483 760 644
http://www.optichrome.com 
--------------------------------------------





More information about the Python-list mailing list