Problems Finding and installing Tkinter

Jim Cochrane jtc at dimensional.com
Fri Nov 26 19:41:17 CET 1999


I've been trying, with no success, to install the Tkinter package for
developing GUIs in Python.  First I tried downloading the latest version
I could find on the net, as well as the latest version of Python, to
make sure everything was in synch.  I then ran into problems with
libraries needed for Tkinter.  After downloading and installing several,
including tkinter, I still had problems and gave up.  (All of these were
.rpm files.  The last error I remember getting was for an unresovled
symbol:  __bzero.)

Next I tried uninstalling everything I had installed, and then
installing the version of Tkinter in my SuSE distribution (and
reinstalling Python).  (I'm using SuSE 6.1.)  I made sure all the needed
packages were installed, such as tk and tcl.  Again, no luck.  When
I try to execute a simple example:

#!/usr/bin/env python

from Tkinter import *
widget = Label (None, text = 'Hello GUI word!')
widget.pack()
widget.mainloop()

I get the following error message:

Traceback (innermost last):
  File "gui1.py", line 3, in ?
    from Tkinter import *
  File "/usr/lib/python1.5/lib-tk/Tkinter.py", line 5, in ?
    import _tkinter # If this fails your Python is not configured for Tk

ImportError: /usr/X11R6/lib/libtk8.0.so: undefined symbol: panic

So it's not finding a symbol named "panic".  I have no idea what library
this should be in.

Any help, clues, or pointers would be appreciated.  Also, I think
another way to do this might be to download and install the latest
version of everything needed for Tkinter - as I tried to do before - but
obtaining everything from the same place as one consistent package.
Does anyone know if this is possible and, if so, where I should look for
this?

Thanks!

Jim Cochrane
jtc at dimensional.com





More information about the Python-list mailing list