Building wxPython [was Re: wxPython and DISLIN work nicely together]

Randall Hopper aa8vb at yahoo.com
Mon Nov 22 19:55:53 CET 1999


Robin Dunn:
 |This makes me wonder how you built wxWindows at all if these errors are in
 |the wxWindows headers...  What about the wxWindows sample apps, do they
 |compile?

Beats me but wxWindows worked out of the box.  configure, make, make
install.  I hadn't run any wxWindows test progs, but I just built/ran bombs
and it worked fine (minus a missing linker -rpath flag which some newer
toolkits don't get right for a while on Solaris, IRIX, FreeBSD, etc.).

BTW, I rebuilt and wxconfig --cflags looks as described now.

With the helpers.cpp NULL hack I just described, it got to the point of
linking wxcmodule.so, and failed trying to find wxPyHelpers:

    CC  -shared -all wx.o windows.o windows2.o windows3.o events.o misc.o misc2.o gdi.o mdi.o controls.o controls2.o cmndlgs.o stattool.o frames.o image.o printfw.o sizers.o clip_dnd.o -L/home/rhh/software/wxGTK-2.1.11/utils/wxPython/src `wx-config --libs`  -lwxPyHelpers   -o wxcmodule.so
    C++ prelinker: warning: could not locate library -lwxPyHelpers; assuming /usr/lib/libwxPyHelpers.a
    ld32: FATAL   9  : I/O error (-lwxPyHelpers): No such file or directory
    gmake: *** [wxcmodule.so] Error 2

build.py assumes that the utils/ directory is named wxPython.  I just left
it wxPython-2.1.11 since the README.txt file said "preferably...wxPython").

I'm also building under the wxGTK build tree's utils/ dir since I didn't
see whether wxPython expected to build under the wxGTK build or installed
trees, and under the build tree made more sense.  Judging from the default
search path of -L$(WXWIN)/utils/wxPython/src for files in the wxPython
build tree (WXWIN being the wxGTK installed tree), now I'm changing my
guess.  Which should it be?

Thanks,

Randall


-- 
Randall Hopper
aa8vb at yahoo.com




More information about the Python-list mailing list