Python 1.6a2 crashes in test_fork1 on my Mandrake Linux 7 machine

Oliver Andrich oli at rz-online.net
Fri Apr 14 19:03:08 CEST 2000


Hi,

On Fri, Apr 14, 2000 at 03:47:18PM +0200, Thomas Wouters wrote:
> I dont know enough about threads to say anything useful about this, but it
> is kind of strange that you dont see the same problem under Python 1.5.2. My
> redhat boxes pass the test, though the BSDI boxes dont (but threading is
> screwed in more than one way under most BSDI versions.) I haven't tried
> compiling 1.5.2 under BSDI 4.1 (the newest, which seems to work reasonably
> ok with threading) though, so it might be a change in python's
> thread-handling...

this is the interesting thing. The system is the same where I run python 1.5.2
and 1.6a2 on. Threading code seems to be the same in the source distribution.
As far as I checked it. It is getting stranger and stranger. 

> Wasn't Mandrake based on Redhat ? Does it use a different/strange libc or
> something ? i dont quite see why there should be a difference in rh 6.1 and
> mandrake, in this context.

Well, they use the same glibc and so should behave equivalent. Only possible
source of errors is the different gccs they use. In python 1.5.2 the gcc of
Mandrake 6 killed the long integer code when optimizations were turned on.
Without it worked. May be we have a again a code generation problem on
Mandrake 7.

Bye, Oliver




More information about the Python-list mailing list