Trouble compiling PyGreSQL 2.4 on Linux

Martin Skøtt mskott at image.dk
Sun Apr 23 21:18:30 CEST 2000


Hi 
I'm trying to compile the PyGreSQL 2.4 module on my Red Hat Linux 6.1
box. I use the following command:

gcc -fpic -shared -o _pg.so -I/usr/include/python1.5
-I/usr/local/pgsql/include pgmodule.c -lpq

With the following result:
pgmodule.c: In function `pgconnect':
pgmodule.c:694: warning: passing arg 4 of `PyArg_ParseTupleAndKeywords' from incompatible pointer type
/usr/bin/ld: cannot open -lpq: No such file or directory

I can't use the make command mentioned in the readme.linux file
because the simply isn't any make file in the archive. Can you help me
getting it compiled?

And a little addon queston:
How stable is the DB-API version of the PostgreSQL module? Can it
be used for production work (or semi serious)?

-- 
Martin Skøtt
mskott at image.dk

'In a certain sense, all decent programming languages are equally powerfull'
Dr. Alan Turing



More information about the Python-list mailing list