Why Won't This Work?

Thomas Wouters thomas at xs4all.net
Sat Dec 23 21:53:25 CET 2000


On Sat, Dec 23, 2000 at 12:18:40PM -0800, Ben Ocean wrote:

> Hmmm. *python* at a command prompt, sans *./* is a command.
> This worked when I configured 2.0, which I had to rip out because it's not
> compatible with Zope.

'python' *with* './' is a command as well. './python' attempts to start the
python binary in your current directory. If that fails, you don't have a
python binary in your current directory, or it isn't executable :)

The problem with 'python' seems to be that there is no 'python' binary in
your PATH (the standard search-path for executables) according to your
shell. If you really ripped out Python 2.0, and did 'make install' in a
1.5.2 tree, it could very well be that your shell hasn't registered the fact
that you have a new binary. Try doing 'rehash' or 'hash -r' (depending on
your shell) to 'reset' it.

Another possibility is that you don't have /usr/local/bin/ in your path, or
you passed a different --prefix to python's configure and don't have that in
your path. All the above can only be the problem if you didn't already do
'make install' in the Python 1.5.2 sourcetree. From your mail it isn't clear
whether you did that yet or not.

> Also, I tried *make test*
> [webmaster at thor Zope-2.2.4-src]$ make test
> make: *** No rule to make target `test'.  Stop.

> Any other ideas as to why I'm not getting my installation of Python 1.5.2
> to respond?

Well, is your problem python 1.5.2, or Zope ? If you want to install python
1.5.2, you shouldn't first try to install Zope ;) The 'make test' I was
referring to is the python 'make test', so you should do it in the python
1.5.2 sourcetree, not the zope one.

-- 
Thomas Wouters <thomas at xs4all.net>

Hi! I'm a .signature virus! copy me into your .signature file to help me spread!




More information about the Python-list mailing list