Compiling Python 2.0 with Berkeley DB 3.0.55?

Carsten Gaebler cg at schlund.de
Fri Dec 15 18:28:40 CET 2000


Robin Dunn wrote:
> > In our company we have a Linux server with the Berkeley DB 3.0.55
> > installed and some DB-3.0.55 files. I compiled Python 2.0 out of the box
> > on that machine and the dbhash module worked fine for the DB files. But
> > on my own workstation I get the error message "Invalid argument" from
> > dbhash.open() when I try to open a DB-3.0.55 file. I compiled Berkeley
> > DB 3.0.55 and replaced the db*.h files in /usr/include/ and libdb.a in
> > /usr/lib/ but it just won't work. Any hints?
> >
> 
> Is this is on an existing file created on the other system?

Yes.

> Can you create and use new files with dbhash.open()? 

Yes. But if I run db_dump on these files, it says "unexpected file type
or format", regardless which db_dump version I use (2.0.77, 3.0.55,
3.1.17)

> If so the file may have become corrupted or something.

I transferred it via scp, so I don't expect any corruption.

>  Try running db_verify (one of the utilities built
> when you compiled DB) on the file and see what it tells you.

There is no db_verify among my Berkeley DB utilities.

> P.S. In case you are interested, the next generation of Berkeley DB wrappers
> is available at http://pybsddb.sourceforge.net/

Yes, I've seen that, but for now I'd like to get that "basic stuff"
working.


cg.



More information about the Python-list mailing list