Bug: Readline getting stuck on Linux and Solaris

Michael Hudson mwh21 at cam.ac.uk
Thu Dec 7 10:57:23 CET 2000


quinn at lira.ugcs.caltech.edu (Quinn Dunkan) writes:

> Strange.. readline has *never* worked right for me, on IRIX or
> Linux, on any version of python (1.4, 1.5.2, 2.0), and any version
> of readline (3.0, 4.0, 4.1), if python is compiled with threads.
> IRIX (6.4, 6.5, 6.5.2) hangs, Linux (2.0.36, 2.2.12, 2.2.17) exits.

Well, I have readline 2.2.1, which may make a difference.  Can you
supply a stacktrace?

> I just tried your 'while 1: pass' thing, and the behaviour is the same there
> too.

That really is odd, because readline doesn't have control then and
should be out of the picture.  Does control-C work as expected here if
readline isn't enabled, or if you hit it before the first prompt
appears (this may be tricky).

Cheers,
M.

-- 
  Ya, ya, ya, except ... if I were built out of KSR chips, I'd
  be running at 25 or 50 MHz, and would be wrong about ALMOST
  EVERYTHING almost ALL THE TIME just due to being a computer!
                                              -- Tim Peters, 30 Apr 97



More information about the Python-list mailing list