Naming conventions

Stefan Schwarzer s.schwarzer at ndh.net
Thu Jan 6 14:24:39 EST 2000


Hi,

are there common naming conventions for Python (functions,
classes, variables ...)?

>From the code I have seen, I suppose the following naming styles:

variable   this_is_a_variable
class      ThisIsAClass (or This_is_a_class?)
function   this_is_a_funtion
module     ThisIsAModule, thisisamodule (or what else?)

Have I forgotten something; do you have more remarks or hints?

Stefan



More information about the Python-list mailing list