Python+SSL+Apache+PyApache problem

louis_wang at my-deja.com louis_wang at my-deja.com
Tue Mar 7 01:58:20 CET 2000


I'm not sure where the problem lies, exactly, but here's my problem.

I'm running in an HPUX environment. I have Apache 1.3.9 + SSL installed
and running. I have Python 1.5.2 + SSL also installed and running. I'm
trying to install PyApache to improve performance on some Python scripts
we're using, and am getting some errors.

The module, mod_pyapache.so, compiles fine(without errors), but when I
try to start the apache server with the appropriate LoadModule, it craps
out, and httpsd refuses to start.

Running a configtest gives the following info:

/usr/lib/dld.sl: Unresolved symbol: SSLv23_method (code)  from
/usr/local/apache/libexec/mod_pyapache.so
Syntax error on line 216 of /usr/local/apache/cof/8888.httpsd.conf:
Cannot load /usr/local/apache/libexec/mod_pyapache.so into server:
Unresolved external

My compilation string is as follows:
/usr/local/apache/bin/apxs -c \
-I/usr/local/ssl/include -I/usr/local/ssl/include/openssl
-I/opt/zlib/include \
-L/usr/local/lib/python1.5/config -L/usr/local/ssl/lib -L/opt/zlib/lib \
-lz -lssl 0lcrypto -lpython1.5 -lm -lpthread mod_pyapache.c

apxs has also been modified:
I've added the -Wl,-E -DUSE_SSL flags to the $CFG_CFLAGS variable
the $CFG_LDFLAGS_SHLIB also has -E -B symbolic -B verbose
/usr/local/lib/gcc-lib/hppa2.0w-hp-hpux11.00/2.95.2/libgcc.a as flags.


Any comments or suggestions?

Thanks in advance!

Louis


Sent via Deja.com http://www.deja.com/
Before you buy.



More information about the Python-list mailing list