Tcl/Tk Path problems in Python 1.5.2 installation

bmark987 at my-deja.com bmark987 at my-deja.com
Thu Mar 30 21:10:13 CEST 2000


Caveat Emptor (Latin for "Buyer Beware")
------------------------------------------------
I had the same problem. My installation on Win95 (of the stock Python
1.52 with the TCL 8.0) worked fine. After a few weeks any Python
program which needed TCL would fail with the "Cannot find
usable 'init.tcl' file in...".
Even the Idle shell, which worked before, was broken. Thanks to the
post below, the problem is fixed by removing the 2 1997 DLLs mentioned
in the post below.
I've tracked it down, and found that the culprit was SpecTCL from sun
which said during the installation that it
"needs to install a special version of TCL 8.0 on your computer"
Boy did it ever! It would have been nice if it has also told me that
it put those DLLs in ..\windows\system!
Worse, the SpecTCL program won't de-install with add/remove programs!
Beware of other programs (from Sun?) that may do this. I've taken the
approach that right after I install a new TCL program, I try running
IDLE and make sure that the new program hasn't broken my Python/TCL
configuration. This avoids the "time bomb" type problem, where the
install breaks TCL and you don't find out about it until the mext time
you try running it (which could be months later).
Note that once you have these bad TCL DLLs, de-intalling and
reinstalling Python and TCL DOES NOT FIX THE PROBLEM. You have to
manually remove these files from your ..\windows\system folder!
Also note that pure TCL program work fine! For example the "Widget
Tour" runs great.
Hope this helps you!
Thanks Dave!!!
The ZipGuy
Freeware Zip Program Reviews at http://over.to/zipguy


Sent via Deja.com http://www.deja.com/
Before you buy.



More information about the Python-list mailing list