Mac OS X threads

Roger Klaveness rogerkl at
Sat Mar 4 12:40:05 CET 2000

John Deighan wrote:
> I was able to compile Python under Mac OS X. However, when I tried to
> install Zope (, it said that it needed Python with thread
> support. When I tried to recompile Python with thread support (using
> "configure --with-threads), it failed because it couldn't link to 3
> thread-related functions. Can anyone help?

try to download and install pthread for Mac Os X :
then you should be able to do a configure --with-threads
and make it succesfully.
You will probably run into another problem when installing Zope
Zope depends on some c-extensions to python that it tries to 
compile as dynamic loadable modules. I couldn't get it to work as it 
seemed to me that python's configure-script cannot make dynamic loadable 
modules for Mac Os X. So what I did was to compile a new python with the 
modules compiled static into the interpreter instead.
What I did was that after running the script, I tweaked the
Setup script in Zope-dir/lib/python, removed 
the *shared* - tag in the top of the file and included the Setup-files
the subdirectories under, that included c-extensions. 
Then I ran
  make -f boot
  make python
Then I had a brand new python-binary with the extensions compiled into
Use this python-binary to run with , and you should have Zope
running on Mac Os X 

Roger Klaveness

More information about the Python-list mailing list