Linux and Python install problem

Matthew Miller matthewm at zebrasoft.co.nz
Thu May 4 23:26:16 CEST 2000


Thanks for your reply Martin. I'm running Caldera OpenLinux 2.3. I've
tried the Redhat rpm from python.org, but doesn't install correctly on
COL2.3, so I've downloaded the py152.tgz from python.org, and tried to
install from that. I've written some shell scripts and they all execute
fine, so I'm baffed as to why ./configure doesn't work - something
simple no doubt. The COL2.3 distro contains a rpm for python-1.5.1, but
part of my reason for installing python-1.5.2 and maybe 1.6 is to become
more comfortable with using shell scripts to install stuff. 

"Martin Skøtt" wrote:
> 
> Matthew Miller <matthewm at zebrasoft.co.nz> writes:
> 
> > Hi everyone,
> >
> > I'm REALLY new to Linux and I'm stuck. I've downloaded python-1.5.2 and
> > untarballed the distro. However, when I run the configure shell script
> > using ./configure, bash reports "No such file or directory". I'm doing
> > this from within the python directory (ie: not a path issue as far as I
> > can tell) and have ensured execute permissions are set etc. Any ideas?
> > Thanks...
> 
> Before you start installing to much, which distro are you running? I
> guess that the majority of Linux distributions today all include
> Python in some strange package format. Try and check your CD or
> download server to see if somebody has done all the work for you.
> On Red Hat all software packages are placed in the RedHat/RPMS/
> directory. Try doing an ls | grep python in that directory and
> install the pachages using rpm -ivh <packge-name.rpm> If you are
> running Red Hat I guess most of Python has allready been installed
> because many of the Red Hat setup tools are written in Python.
> 
> --
> Martin Skøtt
> mskott at image.dk
> 
> 'In a certain sense, all decent programming languages are equally powerfull'
> Dr. Alan Turing

-- 
Matthew Miller
Zebra Software Ltd.

E-mail: matthewm at zebrasoft.co.nz
Ph: 025-2920625 / FAX: 03-3842397



More information about the Python-list mailing list