pyApache install

chibaA at TinterlogD.Tcom chibaA at TinterlogD.Tcom
Tue May 16 16:59:45 CEST 2000


Sorry, let me a bit clear on the last comment I made.  How would I go
about replacing all of my include files.  I downloaded the rpm for the
GCC compiler I have, - would that be enough, or are there other rpms
that I would have to re-install to get those include files?

I installed this rpm:
egcs-1.1.2-24.i386.rpm

Off the RH6.1 distribution.  I don't know if it replaced the include
files --> I did to a recompile after installing this rpm with the
--force switch (to force replacement of files),and I still got the
same error with apache.

kc

On Tue, 16 May 2000 14:41:01 GMT, chibaA at TinterlogD.Tcom wrote:

>The only error that I receive (when using apachectl start) is:
>
>/usr/local/apache/bin/apachectl start: httpd could not be started
>[root at linux apache_1.3.12]#
>
>If I just try it as ./httpd, then I get "Segmentation Fault".  
>
>I figured the defaults would at least allow me to compile correctly
>(compile for make, and make install work fine - with no errors; it
>just makes a faulty executable!?!) -- but I guess not.
>
>Re: could gcc be too new?  Maybe I suppose.  But would RH distribute a
>gcc that would be incompatible with compiling something as standard as
>apache?  (6.2 I believe is the newest, I have RH6.1).  I'd imagine
>more people would have problems doing simple things as I - if that
>were the case.  Actually, I remember I had to copy some .h files into
>my include directories (WAY back..).  Is there anyway to reinstall all
>of the GCC files & includes?  (ie. where might I find the package to
>do so?
>
>Thanks for all your help,
>
>kc
>
>
>
>
>On Tue, 16 May 2000 08:21:10 +0000 (GMT), Oleg Broytmann
><phd at phd.russ.ru> wrote:
>
>>On Tue, 16 May 2000 chibaA at TinterlogD.Tcom wrote:
>>> I'm having problems figuring out how to install pyApache.  Actually,
>>> the root of it might have something to do with problems getting the
>>> compiled apache server to run.  If anyone has successfully recompiled
>>> apache with pyapache (or.. even recompiled apache), could you lend me
>>> a hand here?
>>
>>   I did it many times, pretty successfully.
>>
>>> Basically, if I try and run ./configure, everything goes well (and
>>> seemingly imports modules & stuff fine), the installation finishes,
>>> and the apache directory & executables are all there.  I go to run
>>> apachectl start - and it gives me an unable to start message.  If I
>>> just try running ./httpd, it just says segmentation fault.
>>
>>   Any more details? Any error message?
>>
>>> Any ideas?  I'm running RH6.1, I have the rpm version of apache
>>> 1.3.9-4 running already (but I killed the process while trying the
>>> rebuilt one).  I compiled (with and without pyapache) using apache
>>> 1.3.9 (and for kicks, tried 1.3.12 as well) - but the same problem
>>> each time (segmentation fault).  When I type gcc -v, it returns gcc
>>> version egcs-2.91.66 (which I assume is new enough - came with RH6.1).
>>
>>   May be it is TOO new? I use gcc-2.7.2.3 and 2.8.1...
>>
>>Oleg.            (All opinions are mine and not of my employer)
>>---- 
>>    Oleg Broytmann      Foundation for Effective Policies      phd at phd.russ.ru
>>           Programmers don't die, they just GOSUB without RETURN.
>>
>>
>




More information about the Python-list mailing list