installation (linux)

Thomas Wouters thomas at xs4all.net
Tue May 30 22:08:41 CEST 2000


On Tue, May 30, 2000 at 08:15:59PM +0200, Thomas Thiele wrote:

> At the moment I'm trying to install python on linux(Suse).

> ./configure --prefix=/usr/local/python/
> make 
> make test
> make install
> 
> All worked fine but I have no module thread
> so I tried it once again.
> 
> typing: ./configure --prefix=/usr/local/python/ --with-threads

[...]

> make says at the end:
> /usr/local/python/Python-1.5.2/Modules/./threadmodule.c:281: undefined
> reference to `PyEval_InitThreads'

[...]

> What can be wrong? What have I to do? 

You have to clean up leftover cruft after the reconfigure. Try

make clean
make

If you still get the error, do this instead:

mv Modules/Setup Modules/Setup.old
make distclean
./configure --prefix=/usr/local/python/ --with-threads
cp Modules/Setup.old Modules/Setup
make

and you should have no problems.

-- 
Thomas Wouters <thomas at xs4all.net>

Hi! I'm a .signature virus! copy me into your .signature file to help me spread!




More information about the Python-list mailing list