Pyncurses on Slackware 7 with python 1.5.2

Eidd eidd at beerninjas.org
Mon May 8 07:06:14 CEST 2000


I get the following error when i run ./setup.py build for PyNcurses 0.3 on
Slackware 7 with python 1.5.2. gcc -c -I/usr/include/python1.5 -g -O2
-fpic ncurses/_curses_wrap.c -o
build/temp.linux2-i586/ncurses/_curses_wrap.o ncurses/_curses_wrap.c:1139:
conflicting types for `keyname'
/usr/include/curses.h:504: previous declaration of `keyname'
ncurses/_curses_wrap.c:1150: conflicting types for `newterm'
/usr/include/curses.h:638: previous declaration of `newterm'
ncurses/_curses_wrap.c:1200: conflicting types for `tigetflag'
/usr/include/curses.h:713: previous declaration of `tigetflag'
ncurses/_curses_wrap.c:1201: conflicting types for `tigetnum'
/usr/include/curses.h:714: previous declaration of `tigetnum'
ncurses/_curses_wrap.c:1202: conflicting types for `tigetstr'
/usr/include/curses.h:715: previous declaration of `tigetstr'
ncurses/_curses_wrap.c:1207: conflicting types for `vwprintw'
/usr/include/curses.h:735: previous declaration of `vwprintw'
ncurses/_curses_wrap.c:1208: conflicting types for `vwscanw'
/usr/include/curses.h:737: previous declaration of `vwscanw'
error: command 'gcc' failed with exit status 1

Has anyone else experienced this error or know how to fix it . Thank you
--David




More information about the Python-list mailing list