Basic help wanted: building on unix

Suchandra Thapa ssthapa at
Sat Nov 18 19:24:27 CET 2000

Erik Max Francis <max at> wrote:
>> The computer came without a C comiler. I'm planning to install Gnu C
>> version 2.95.2, the current release, and use the version pre-built for
>> Solaris 8 sparc. Does this sound reasonable?

    You might want to check the sparc bug reports for gcc 2.95.2.  I
know their have been problems with the backend generating incorrect
code for non x86 platforms.  For example, 2.95.1 didn't handle c++ code
with exceptions very well on alphas, parisc, and possibly sparcs.  The
gcc page seems to indicate that 2.95.2 will cause problems with 
lapack if you try to do any optimizations beyond O2 on alphas and sparcs.
Also I've read some messages indicating that 2.95.x can't generate 
proper assembly in some situations, the compiler will stop compilation
and indicate this however.  However, I'm not sure if this was fixed for 
2.95.2. I think gcc 2.91 (egcs) has better support for alphas and sparc than 

Suchandra Thapa             | "There are only two kinds of math books. 
s-thapaNO at  | Those you cannot read beyond the first 
			    | sentence, and those you cannot read 
			    | beyond the first page."
			    |                       -C.N. Yang

More information about the Python-list mailing list