error in Python 2.0 dist?

D-Man dsh8290 at rit.edu
Wed Nov 8 07:14:23 CET 2000


I downloaded the SRPM from python.org.  When I tried building I got the following:

[snip]
gcc -g -O2 -Wall -Wstrict-prototypes -I./../Include -I.. -DHAVE_CONFIG_H   -c -o node.o node.c
In file included from ../Include/Python.h:54,
                 from node.c:3:
./Include/pyport.h:390:2: #error "LONG_BIT definition appears wrong for platform (bad gcc config?)."
make[1]: *** [node.o] Error 1
[snip]


Wondering about this I took a look at the source.  In Includes/pyport.h I found the preprocessor lines defining LONG_BIT and checking it's validity.  Not knowing what was really happening, I made a simple C program to check what LONG_BIT was on my system.  I found that LONG_BIT wasn't defined, and neither was SIZEOF_LONG (which is used to define LONG_BIT).  I grepped the includes and it seemed that SIZEOF_LONG wasn't defined in the python headers either.

I found that sizeof( long ) is 4 for my machine.  I tried defining SIZEOF_LONG to be sizeof( long ) in pyport.h, but no difference.

I have a PentiumII 300 with RH7.0 (gcc 2.96).  Python 1.5.2 runs fine on my machine.

Any thoughts?

-D







More information about the Python-list mailing list