Any Corba 2.3 compliant Python ORBs?

James Logajan JamesL at Lugoj.Com
Tue Sep 5 00:09:46 CEST 2000


Anyone know of any commercial, shareware, or freeware Corba ORBs that are
version 2.3 compliant? Specifically, I'm interested in conformance with
valuetypes. I have looked into ILU, Fnorb, omniORBpy, and orbit-python.
Unless I am missing something, none of these appear to support valuetypes
and none will anytime soon. :-(

My only other alternative, unpleasant as it seems, is to get Object Oriented
Concepts' (http://www.ooc.com) Java ORB and tie it together with JPython.
This hopefully gives me the scripting language syntax I want (Python) with
communications ability to Corba 2.3 servant objects that use valuetypes. But
it appears unnatural....



More information about the Python-list mailing list