Deprecate self
Steve Purcell
stephen_purcell at yahoo.com
Wed Apr 18 11:10:43 EDT 2001
Rainer Deyke wrote:
> My C++ code has become much more readable since I started referring to
> member variables through 'this'.
I had the same experience with Java. Writing 'this' also helps to avoid
having to artificially mutate variable names that are logically related
in code such as:
class Blah {
Foo foo;
Blah(Foo foo) {
this.foo = foo;
}
...
}
Now, I've admittedly been corrupted by Python, but I know some Java purists
who like this ('this'?) style too.
-Steve
--
Steve Purcell, Pythangelist
Get testing at http://pyunit.sourceforge.net/
Any opinions expressed herein are my own and not necessarily those of Yahoo
More information about the Python-list
mailing list