PyQt install problem

Bruce Wolk bawolk at
Wed Aug 8 06:06:15 CEST 2001

I compiled the sip-2.4.tar.gz  and   PyQt-2.4.tar.gz versions under
Red Hat 7.1 against Qt2.3 and Python 2.1, both without any errors.  When
I run the PyQt examples as root, I get the following message, but the
examples run:

Session management error: Authentication Rejected, reason : None of the
authentication protocols specified are supported and host-based
authentication failed
Xlib:  extension "RENDER" missing on display ":0.0".

When I run as a normal user, I get the following error message:

Traceback (most recent call last):
  File "./", line 4, in ?
    from qt import *
  File "/usr/lib/python2.1/site-packages/", line 43, in ?
    import libqtc
ImportError: /usr/lib/python2.1/site-packages/ undefined
symbol: __11QSizePolicyQ211QSizePolicy8SizeTypeT1b

I have tried everything I can think of to solve this problem, but am
stumped.  Does anyone have any ideas?


More information about the Python-list mailing list