compiling Python 2.1.1

Roman Suzi rnd at onego.ru
Mon Aug 27 17:46:17 CEST 2001


On Mon, 27 Aug 2001, Ignacio Vazquez-Abrams wrote:

> On Mon, 27 Aug 2001, Roman Suzi wrote:
> 
> > Hello,
> >
> > I am trying to compile Python 2.1.1 on my Linux RedHat 6.2
> > system and am getting
> >
> > # rpm -bb python-2.1.spec
> > error: failed build dependencies:
> >         expat-devel >= 1.1-3tummy is needed by python2-2.1.1-1
> >         db1-devel   is needed by python2-2.1.1-1
> >
> > While I have even two versions of expat:
> >
> > # rpm -qa | grep expat
> > expat-1.1-1
> > expat-1.1-3tummy
> >
> > The question is, where can I find appropriate expat-devel
> > rpm? (expat-1.1-3tummy.src.rpm doesn't produce one, as
> > expected, and rpmfind warns that expat tummy RPMs "doesnt export
> > valid resources list")
> >
> > Sincerely yours, Roman A.Suzi
> 
> 1.1? Ouch.
> 
>   ftp://ftp.rpmfind.net/linux/sourceforge/expat/expat-1.95.2-1.src.rpm

This doesn't provide expat-devel (that is, includes and libs).
 
> db1 may be trickier. IIRC, there's some sort of conflict with 6.2 and the db1
> packages from 7.x. Nonetheless:
> 
>   ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/os/i386/SRPMS/db1-1.85-5.src.rpm

Trickier indeed:

# rpm -hiv db1-1.85-5.i386.rpm db1-devel-1.85-5.i386.rpm
error: failed dependencies:
        glibc < 2.1.90 conflicts with db1-1.85-5
        glibc-devel < 2.1.90 conflicts with db1-devel-1.85-5

How people compile Python 2.1.1 from src.rpm on not-so-ancient RedHat 6.2
(without tricks)???

I do not believe Python 2.1.1 requires RedHat 7.x to compile
and run, but that is what official src.rpm for it insists.

Maybe I could find alternative spec-file?

> Knock yourself out.

Sincerely yours, Roman A.Suzi
-- 
 - Petrozavodsk - Karelia - Russia - mailto:rnd at onego.ru -
 






More information about the Python-list mailing list