Troublesome PIL Installation

Christian Lundh xistan at yahoo.se
Wed Aug 29 10:43:18 CEST 2001


Hi,

I've been trying to install PIL using Active-Python 2.1.1 on a HP-UX
10.20 box. (Same problem with plain Python2.1 distribution.) I just
can't get through the installation process. The libImaging library
builds just fine, but then comes the Makefile.pre.in step.

I get the following message when running 'make -f Makefile.pre.in
boot'

rm -f *.o *~
rm -f *.a tags TAGS config.c Makefile.pre python sedscript
rm -f *.so *.sl so_locations
VERSION=`python -c "import sys; print sys.version[:3]"`; \
installdir=`python -c "import sys; print sys.prefix"`; \
exec_installdir=`python -c "import sys; print sys.exec_prefix"`; \
make -f ./Makefile.pre.in VPATH=. srcdir=. \
        VERSION=$VERSION \
        installdir=$installdir \
        exec_installdir=$exec_installdir \
        Makefile
make[1]: Entering directory
`/home/xistan/src/ActivePython-2.1.1-212/Extensions/Imaging'
make[1]: *** No rule to make target
`/home/xistan/lib/python2.1/config/Makefile'.  Stop.
make[1]: Leaving directory
`/home/xistan/src/ActivePython-2.1.1-212/Extensions/Imaging'
make: *** [boot] Error 2


When I checked, I noticed that the ~/lib/python2.1/config directory
was not present. Even if I create the config directory I get the same
message. I built the python distribution successfully. Apparently I
must be missing something here. I've searched for answers almost
everywhere, but most people seem to success in this step where I fail.
Does anyone have a clue what this might be all about? Perhaps I am
lacking some files, or rather have them in the wrong place?

Thanks in advance

/Christian Lundh



More information about the Python-list mailing list