Tkinter on IRIX and Linux

Aidan Finn aidan.finn at ucd.ienospam
Wed Aug 22 12:55:19 CEST 2001


Hi,
I just had this problem. When you compile python2.0 from source,
tkinter support is not included by default. you need to uncomment and edit the
parts of the module/setup file relevant to _tkinter. Check out the
tkinter section of the README file that comes with python2.0 for more
details.
Also, i had tk installed on my machine but still couldnt get tkinter
working. tk on my distribution was installed from an rpm and some
required header files were missing. After installing tcl and tk from
source, the python source installation with tkinter support worked fine.

AF

In article <3B81E5FF.49B72C6E at zikai.org>, "Junjun Mao" <jmao at zikai.org>
wrote:

> I compiled Python 2.0 on IRIX and Linux. Neither of them supports
> tkinter. When I import Tkinter:
> 
> File "/usr/lib/python2.0/lib-tk/Tkinter.py", line 35, in ? import
> _tkinter # If this fails your Python may not be configured for Tk
> 
> ImportError: No module named _tkinter
> 
> Should I configure the PYTHONPATH or compile tkinter separately?
> 
> If this has been answered, please point out the link.
> 
> Thanks
> 
> Junjun
>



More information about the Python-list mailing list