Python 1.5.x vs Python 2.x.x

Sean 'Shaleh' Perry shalehperry at attbi.com
Thu Dec 13 07:41:40 CET 2001


On 13-Dec-2001 Angus Mackay wrote:
> there seems to be lots of stuff that refrences python 1.5.x or requires it
> but
> he www.python.org website doesn't mention it at all.
> 
> what is the deal?
> 
> what are people using? it seems to me that python doesn't handle versioning
> at
> all well under windows, if I build a module agains python 2.1 it wont work
> under
> a python 2.2 interpreter at all?
> 

for the most part python modules from 1.5 work under 2.x but not vice versa. 
Compiled modules are dependent on the version of python they were compiled
against.




More information about the Python-list mailing list