MySQLdb "Illegal instruction" error.

Stephen shriek at gmx.co.uk
Sun Dec 23 18:30:36 CET 2001


Roman, you're a legend.  Have got it working ! 
 
> >but the problem still persists (ie. "Illegal Instruction" error and
> >Python exits).
> >
> >I've tried using MySQLdb for Python1.5.2 and the same problem exists.
> >So, that pretty much rules out Python1 vs Python2 problems - now to
> >work out if it's a MySQLdb or MySQL problem.
> 
> Maybe you've used wrong version of Python to compile extension
> module? I remember having problems with threads when compiling
> MySQLdb. Getting latest source solved the problem.

> I also remember MySQLdb has it's own maillist. Probably, you can ask
> MySQLdb author there.

That was the ticket. Went looking for the mailing list but there
isn't one. However, there is a forum at sourceforge and a previous
posting was titled "Illegal Instruction" also on Redhat7.x.
Followed the advice given and it worked for me first time. 

Sincerely relieved and indebted to yourself and the guys (Andy Dustman
and Halokido?) who solved this at sourceforge. 

Merry Christmas indeed. :-)

Stephen



More information about the Python-list mailing list