Python 1.5.x vs Python 2.x.x

Fernando Pérez fperez528 at yahoo.com
Thu Dec 13 00:42:57 CET 2001


Paul Rubin wrote:

> Fernando Pérez <fperez528 at yahoo.com> writes:
>> For some bizarre reason, redhat 7.2 includes two versions of pyhton with
>> 1.5 being the default.
> 
> The reason may be that some of the red hat configuration scripts were
> written under python 1.5, and 2.1 broke backwards compatibility.
> In particular the "rand" module was renamed "random" and maybe changed.

good point. just yesterday I found out about that b/c I screwed up the 
firewalling rules when installing a 7.2 box. Lo and behold, when I went 
digging looking for the installer package (named anaconda), what I found was 
a bunch of python scripts! The entire RedHat installer is a python system 
(hence the name!). This was great, in a few minutes I was able to dig out 
what the name of the underlying firewall configurator (lokkit) was and fixed 
my mistake. 

cheers,
f



More information about the Python-list mailing list