To the point of defeat.....IDLE

Bruce Sass bsass at freenet.edmonton.ab.ca
Tue Feb 27 13:02:05 CET 2001


> First off I can't use the Python2.0 BeOpen RPM at python.org ...When I
> attempt to. The systemsill complain about library dependencies for tcl
> and tk 8.0.
>
> If I download the source for BeOpen 2.0 and do a  "./configure" "make"
> and "make install" the BeOpen software installs.
>
> However...
> If I try to bring up IDLE...it is associated with the 1.5.2 interpreter.
>
> What do I need to do so IDLE will wun with 2.0 instead?

Have a look at the .py executables that came with your py-2.0, I think
you will find that they use #!...python - which results in the
python-1.5.2 interpreter starting up.  Not what you want!

You need to track down all the executable scripts and make sure they
refer to python2.0.   The fixps.py script in the Tools dir of py-2.0
will automate the task - but look at it first and edit it to reflect
your setup (namely, the location of python2.0).


- Bruce





More information about the Python-list mailing list