How Best Get These Components?

D-Man dsh8290 at rit.edu
Mon Feb 12 21:00:16 CET 2001


Whether or not you need them depends on what you want to do.


On Mon, Feb 12, 2001 at 08:31:14AM -0800, Ben Ocean wrote:
| Hi;
| I ran into some strange problems when I re-located my Apache box. Because 
| of that, I (stupidly) ended up ripping out all things python and trying to 
| re-install it. Well, python appears to work now, but I still appear to be 
| missing a bunch of components. Then again, maybe I'm not: if python can't 
| work with the components listed below, then perhaps I have a dead 
| installation and a good one, too. (As an example, Zope works just fine.) 
| What's the easiest way to test for if I really do need these tools? If I 
| *do* need them, how should I go about installing them?
| TIA,
| BenO
| 
| the list...
| 

These are the GTK/GNOME bindings.  There should be a link to James' 
site (the maintainer) from gtk.org and gnome.org.  You only need them
if you want to use programs that use gtk or gnome (for the user
interface).

| missing    /usr/lib/python1.5/site-packages/_appletmodule.so
| missing    /usr/lib/python1.5/site-packages/_cappletmodule.so
| missing    /usr/lib/python1.5/site-packages/_gnomemodule.so
| missing    /usr/lib/python1.5/site-packages/_gnomeuimodule.so
| missing    /usr/lib/python1.5/site-packages/_gtkxmhtmlmodule.so
| missing    /usr/lib/python1.5/site-packages/gnome/__init__.py
| missing    /usr/lib/python1.5/site-packages/gnome/__init__.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/__init__.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/affine.py
| missing    /usr/lib/python1.5/site-packages/gnome/affine.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/affine.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/applet.py
| missing    /usr/lib/python1.5/site-packages/gnome/applet.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/applet.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/capplet.py
| missing    /usr/lib/python1.5/site-packages/gnome/capplet.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/capplet.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/config.py
| missing    /usr/lib/python1.5/site-packages/gnome/config.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/config.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/file.py
| missing    /usr/lib/python1.5/site-packages/gnome/file.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/file.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/help.py
| missing    /usr/lib/python1.5/site-packages/gnome/help.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/help.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/history.py
| missing    /usr/lib/python1.5/site-packages/gnome/history.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/history.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/metadata.py
| missing    /usr/lib/python1.5/site-packages/gnome/metadata.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/metadata.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/mime.py
| missing    /usr/lib/python1.5/site-packages/gnome/mime.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/mime.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/score.py
| missing    /usr/lib/python1.5/site-packages/gnome/score.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/score.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/triggers.py
| missing    /usr/lib/python1.5/site-packages/gnome/triggers.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/triggers.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/ui.py
| missing    /usr/lib/python1.5/site-packages/gnome/ui.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/ui.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/uiconsts.py
| missing    /usr/lib/python1.5/site-packages/gnome/uiconsts.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/uiconsts.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/url.py
| missing    /usr/lib/python1.5/site-packages/gnome/url.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/url.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/xmhtml.py
| missing    /usr/lib/python1.5/site-packages/gnome/xmhtml.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/xmhtml.pyo
| missing    /usr/lib/python1.5/site-packages/gnome/zvt.py
| missing    /usr/lib/python1.5/site-packages/gnome/zvt.pyc
| missing    /usr/lib/python1.5/site-packages/gnome/zvt.pyo
| missing    /usr/lib/python1.5/site-packages/GDK.py
| missing    /usr/lib/python1.5/site-packages/GDK.pyc
| missing    /usr/lib/python1.5/site-packages/GDK.pyo
| missing    /usr/lib/python1.5/site-packages/GTK.py
| missing    /usr/lib/python1.5/site-packages/GTK.pyc
| missing    /usr/lib/python1.5/site-packages/GTK.pyo
| missing    /usr/lib/python1.5/site-packages/GdkImlib.py
| missing    /usr/lib/python1.5/site-packages/GdkImlib.pyc
| missing    /usr/lib/python1.5/site-packages/GdkImlib.pyo
| missing    /usr/lib/python1.5/site-packages/GtkExtra.py
| missing    /usr/lib/python1.5/site-packages/GtkExtra.pyc
| missing    /usr/lib/python1.5/site-packages/GtkExtra.pyo
| missing    /usr/lib/python1.5/site-packages/Gtkinter.py
| missing    /usr/lib/python1.5/site-packages/Gtkinter.pyc
| missing    /usr/lib/python1.5/site-packages/Gtkinter.pyo
| missing    /usr/lib/python1.5/site-packages/_gdkimlibmodule.so
| missing    /usr/lib/python1.5/site-packages/_gtkmodule.so
| missing    /usr/lib/python1.5/site-packages/gtk.py
| missing    /usr/lib/python1.5/site-packages/gtk.pyc
| missing    /usr/lib/python1.5/site-packages/gtk.pyo
| missing    /usr/lib/python1.5/site-packages/pyglade/__init__.py
| missing    /usr/lib/python1.5/site-packages/pyglade/__init__.pyc
| missing    /usr/lib/python1.5/site-packages/pyglade/__init__.pyo
| missing    /usr/lib/python1.5/site-packages/pyglade/build.py
| missing    /usr/lib/python1.5/site-packages/pyglade/build.pyc
| missing    /usr/lib/python1.5/site-packages/pyglade/build.pyo
| missing    /usr/lib/python1.5/site-packages/pyglade/style.py
| missing    /usr/lib/python1.5/site-packages/pyglade/style.pyc
| missing    /usr/lib/python1.5/site-packages/pyglade/style.pyo
| missing    /usr/lib/python1.5/site-packages/pyglade/xmlparse.py
| missing    /usr/lib/python1.5/site-packages/pyglade/xmlparse.pyc
| missing    /usr/lib/python1.5/site-packages/pyglade/xmlparse.pyo


Looks like this is the Tkinter bindings.  I don't know where to get
them.  It should have been included in the standard dist.  I don't
know what to do (since you built your own, right?)  These are only
necessary if you want to run programs using Tkinter for the UI.

| missing    /usr/lib/python1.5/lib-dynload/_tkinter.so
| missing    /usr/lib/python1.5/lib-tk
| missing    /usr/lib/python1.5/lib-tk/Canvas.py
| missing    /usr/lib/python1.5/lib-tk/Canvas.pyc
| missing    /usr/lib/python1.5/lib-tk/Canvas.pyo
| missing    /usr/lib/python1.5/lib-tk/Dialog.py
| missing    /usr/lib/python1.5/lib-tk/Dialog.pyc
| missing    /usr/lib/python1.5/lib-tk/Dialog.pyo
| missing    /usr/lib/python1.5/lib-tk/FileDialog.py
| missing    /usr/lib/python1.5/lib-tk/FileDialog.pyc
| missing    /usr/lib/python1.5/lib-tk/FileDialog.pyo
| missing    /usr/lib/python1.5/lib-tk/FixTk.py
| missing    /usr/lib/python1.5/lib-tk/FixTk.pyc
| missing    /usr/lib/python1.5/lib-tk/FixTk.pyo
| missing    /usr/lib/python1.5/lib-tk/ScrolledText.py
| missing    /usr/lib/python1.5/lib-tk/ScrolledText.pyc
| missing    /usr/lib/python1.5/lib-tk/ScrolledText.pyo
| missing    /usr/lib/python1.5/lib-tk/SimpleDialog.py
| missing    /usr/lib/python1.5/lib-tk/SimpleDialog.pyc
| missing    /usr/lib/python1.5/lib-tk/SimpleDialog.pyo
| missing    /usr/lib/python1.5/lib-tk/Tkconstants.py
| missing    /usr/lib/python1.5/lib-tk/Tkconstants.pyc
| missing    /usr/lib/python1.5/lib-tk/Tkconstants.pyo
| missing    /usr/lib/python1.5/lib-tk/Tkdnd.py
| missing    /usr/lib/python1.5/lib-tk/Tkdnd.pyc
| missing    /usr/lib/python1.5/lib-tk/Tkdnd.pyo
| missing    /usr/lib/python1.5/lib-tk/Tkinter.py
| missing    /usr/lib/python1.5/lib-tk/Tkinter.pyc
| missing    /usr/lib/python1.5/lib-tk/Tkinter.pyo
| missing    /usr/lib/python1.5/lib-tk/tkColorChooser.py
| missing    /usr/lib/python1.5/lib-tk/tkColorChooser.pyc
| missing    /usr/lib/python1.5/lib-tk/tkColorChooser.pyo
| missing    /usr/lib/python1.5/lib-tk/tkCommonDialog.py
| missing    /usr/lib/python1.5/lib-tk/tkCommonDialog.pyc
| missing    /usr/lib/python1.5/lib-tk/tkCommonDialog.pyo
| missing    /usr/lib/python1.5/lib-tk/tkFileDialog.py
| missing    /usr/lib/python1.5/lib-tk/tkFileDialog.pyc
| missing    /usr/lib/python1.5/lib-tk/tkFileDialog.pyo
| missing    /usr/lib/python1.5/lib-tk/tkFont.py
| missing    /usr/lib/python1.5/lib-tk/tkFont.pyc
| missing    /usr/lib/python1.5/lib-tk/tkFont.pyo
| missing    /usr/lib/python1.5/lib-tk/tkMessageBox.py
| missing    /usr/lib/python1.5/lib-tk/tkMessageBox.pyc
| missing    /usr/lib/python1.5/lib-tk/tkMessageBox.pyo
| missing    /usr/lib/python1.5/lib-tk/tkSimpleDialog.py
| missing    /usr/lib/python1.5/lib-tk/tkSimpleDialog.pyc
| missing    /usr/lib/python1.5/lib-tk/tkSimpleDialog.pyo

Not sure where these come from, but gettext is the GNU library for
internationalizing programs.  These are only necessary if you want to
run programs that use gettext for internationalization.

| missing    /usr/lib/python1.5/site-packages/_zvtmodule.so
| missing    /usr/lib/python1.5/site-packages/gettext.py
| missing    /usr/lib/python1.5/site-packages/gettext.pyc
| missing    /usr/lib/python1.5/site-packages/gettext.pyo


If you don't want to run programs that need these modules, then you
don't need to install them.  If you do (say, netcfg or printtool --
both need Tkinter) then they will crash with a Import Failed, No Such
Module type of message.

You have a RH system right?  You should just be able to install the
rpms.  Of course, since you compiled python from source, rpm will
complain that you are missing python.  Just use --nodeps when you
install.  Also realize that you will "forever" have such issues since
part of your system is rpm-based and part is hand installed from
tarballs.

HTH,
-D





More information about the Python-list mailing list