Newbie Question---IDLE on Linux

Chris Nelson fimafeng at yahoo.com
Sun Feb 25 00:56:45 CET 2001


Hi:
I'm running Red Hat 7.0 which comes with Python 1.5.2 installed by default.
I downloaded the source for 2.0 and Tkinter
The source for 2.0 seems to have finished installing and I can
get the 2.0 interpreter to come up but I have type in the full path
which is   /myinstalls/Python-2.0/python

I have tkinter 1.52 already installed from the inital build of the 
system. Do I still need to upgrade? How do I upgrade the TKinter? I'm 
guessing that it is the setup.py file in the TKiner directory.
When I try to run the program I get the following.....

[root at localhost bin]# python /myinstalls/Tkinter-2.0-8.0/setup.py
Traceback (innermost last):
   File "/myinstalls/Tkinter-2.0-8.0/setup.py", line 8, in ?
     from distutils.core import setup, Extension
ImportError: No module named distutils.core

What AM I doing wrong????

Please help. I'm trying to get IDLE to run....

Chris




More information about the Python-list mailing list