Error Building PyPgSQL

Rod MacNeil rmacneil at interactdirect.com
Mon Jul 9 15:13:36 CEST 2001


Hello,

I'm trying to build PyPgSQL on a RH7 box with
Python 1.5 and postgres 7.0 and gcc-2.96-54.
I left the Setup.in file as it shipped because it looked
correct to me.
I get the following when I run make.

gcc -fPIC -I/usr/local/pgsql/include -g -02 -
I/usr/include/python1.5 -I/usr/include/python1.5 -
DHAVE_CONFIG_H -c ./libpqmodule.c
./libpqmodule.c: In function `PgConnection_New':
./libpqmodule.c:196: parse error before `PgConnection'
./libpqmodule.c: In function `PgResult_New':
./libpqmodule.c:282: parse error before `PgResult'
./libpqmodule.c: In function `PgLargeObject_New':
./libpqmodule.c:358: parse error before `PgLargeObject'
./libpqmodule.c: In function `PgNotify_New':
./libpqmodule.c:548: parse error before `PgNotify'
make: *** [libpqmodule.o] Error 1

This looks like a compiler error to me but I'm not a C programmer.
The four lines of code appear to be
using the same syntax, is this a syntax error or
possibly a compiler version issue?

Has anyone else had this problem or know of a solution?

Thanx, any help would be appreciated.

Rod MacNeil
rmacneil at interactdirect.com





More information about the Python-list mailing list