Weird problem on WIN platform.. any ideas?

Gilles Lenfant glenfant.nospam at bigfoot.com
Thu Jul 5 16:46:32 CEST 2001


Hints,

Use another account for the SQL server agent (in "services" configuration
panel)
Try with your account first (the one used when the command line script
succeds)
Or give access to "v:\" to the account that runs SQL Server agent.

"mixoftheweek.com" <pirkka.hartikainen at visualsystems.com> a écrit dans le
message news: ecfce343.0107042329.54bcd07a at posting.google.com...
> Problem description:
>
> I've got a little Python script using urllib's urlretrieve() function
> to fetch an image from a web site. The script works without errors
> when I run it from the command line.
>
> However, when I schedule SQL Server Agent to run the script, the Agent
> reports the following error:
>
> File "C:\scripts\dailygif.py", line 26, in ?
> urlretrieve(gif_url,gif_filename)
> File "c:\python20\lib\urllib.py", line 68, in urlretrieve      return
> _urlopener.retrieve(url, filename, reporthook, data)
> File "c:\python20\lib\urllib.py", line 212, in retrieve      tfp =
> open(filename, 'wb')  IOError: [Errno 2] No such file or directory:
> 'v:\\images\\dailygif\\dailygif.gif'
>
> As I said, I'm unable to repeat this error when I run the same script
> from command line. The double slashes in the error-causing file path
> are not of my doing (gif_filename =
> 'v:\images\dailygif\dailygif.gif').
>
> Any help would be greatly appreciated! Thanks.





More information about the Python-list mailing list